1.6 to 2.0 SEQUENCE_GENERATOR Migration

Migrating SEQUENCE_GENERATOR table data to be compatible with Broadleaf Commerce 2.0 and beyond

Migration of the data in the SEQUENCE_GENERATOR table is required of all implementations that were already deployed on 1.5 or 1.6 and are upgrading to 2.0.

  • Update the ID_VAL for every ID_NAME to a value greater than the MAX(ID) of the associated table.
  • For example, the ID_NAME of OrderItemImpl is used to track the ids for BLC_ORDER_ITEM. With BLC 2.0, one would need to change the ID_VAL for OrderItemImpl to a value greater than the MAX(ORDER_ITEM_ID) from the BLC_ORDER_ITEM table.
  • If you would like for Broadleaf Commerce to autocorrect these problems by setting the sequence generator value to a value greater than the max entity id, then set the 'auto.correct.sequence.generator.inconsistencies' property to true in your application's or